Fix libwacom9 dependency issue when upgrade Debian

The following packages have unmet dependencies:
libwacom9 : Depends: libwacom-common (= 2.1.0-2) but 1.12-1 is to be

installed

This should fix the issue on most cases:

# apt install libwacom9 libwacom-common=2.1.0-2

If the command above returns error:

E: Version ‘2.1.0-2’ for ‘libwacom-common’ was not found

Try this:

# apt remove libwacom2

When run the command above apt will offer to install libwacom9 > select yes. After that apt upgrade will work as always.

4.7 10 votes
Article Rating
Subscribe
Notify of
guest
6 Comments
Oldest
Newest Most Voted
Inline Feedbacks
View all comments
Winslow
Winslow
2 months ago

you’ll always be an ace in my book

King DoDo
King DoDo
1 month ago

thank you worked with me using (apt remove libwacom2)

Shikezu
Shikezu
1 month ago

Nice, thanks bro it actually work for my Linux 😀

ranafoul
ranafoul
19 days ago

apt remove libwacom2 helped on kali 2022.01. gr8

saintnick
saintnick
16 hours ago

remove libwacom2 worked for me as well

sreedhar
13 hours ago

Thanks its working