laravel url ../public/login not working but ../public/index.php/login works without bootstrap

i’m using laravel to make my website.
after i upload my web files on my sub-domain : rivelapark.com/au
i can’t access rivelapark.com/au/public/login
(*in my local server, localhost/au/public/login did works)

But, when i access rivelapark.com/au/public/index.php/login it works but my bootstrap is not working.

Here is my app>config>database.php:

'mysql' => array(
            'driver'    => 'mysql',
            'host'      => 'rivelapark.com',
            'database'  => '******',
            'username'  => '********',
            'password'  => '*******',
            'charset'   => 'utf8',
            'collation' => 'utf8_unicode_ci',
            'prefix'    => '',
        ),

and this is my public>.htaccess :
<IfModule mod_rewrite.c>
    <IfModule mod_negotiation.c>
        Options -MultiViews
    </IfModule>

    RewriteEngine On

    # Redirect Trailing Slashes...
    RewriteRule ^(.*)/$ /$1 [L,R=301]

    # Handle Front Controller...
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteRule ^ index.php [L]
</IfModule>

Is there anyone could help ? Thank You Guys

Answers:

Thank you for visiting the Q&A section on Magenaut. Please note that all the answers may not help you solve the issue immediately. So please treat them as advisements. If you found the post helpful (or not), leave a comment & I’ll get back to you as soon as possible.

Method 1

http://laravel.com/docs/4.2/installation#pretty-urls

If you use Apache to serve your Laravel application, be sure to enable the mod_rewrite module.
If the .htaccess file that ships with Laravel does not work with your Apache installation, try this one:

    Options +FollowSymLinks
    RewriteEngine On

    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteRule ^ index.php [L]

Did you try to use this example?
mod_rewrite module is enabled?

Method 2

Actually the main problem is the cache of the browser not yet refreshed. After waiting 15 minutes, now it works !


All methods was sourced from stackoverflow.com or stackexchange.com, is licensed under cc by-sa 2.5, cc by-sa 3.0 and cc by-sa 4.0

0 0 votes
Article Rating
Subscribe
Notify of
guest

0 Comments
Inline Feedbacks
View all comments
0
Would love your thoughts, please comment.x
()
x