Unrecognized attribute ‘targetFramework’. Note that attribute names are case-sensitive

I just installed vs 2010, followed by IIS in window 7. when building a website in .net framework 4.0 and convert this into application in IIS then its shows this error

enter image description here

If i remove the targetFramework="4.0" from web config file then it shows me a second error which is related to linq reference error

enter image description here

This all happening when i am using localhost to run my website but whenever i use just f5 in vs 2010 then its run perfectly.

When i want to attach my process with aspnet_wp.exe i don’t find this process in my list.

I searched a lot of answers here. What am I missing.

Answers:

Thank you for visiting the Q&A section on Magenaut. Please note that all the answers may not help you solve the issue immediately. So please treat them as advisements. If you found the post helpful (or not), leave a comment & I’ll get back to you as soon as possible.

Method 1

The problem could be:

  • the Application Pool for your site is configured for .NET Framework Version = v2.0.XXXXX
  • .NET 4 isn’t installed on your server.

See also

… which helped me fix a similar issue.

Method 2

You’ll likely need to re-register ASP.Net version 4 with IIS.

Navigate to your .net framework 4.0 folder, and run aspnet_regiis.exe -i

For example, my .net framework 4.0 folder (Server 2k8 R2 x64) was located at:
C:WindowsMicrosoft.NETFramework64v4.0.30319

Method 3

From Control Panel open IIS manager -> on Left side select “Application Pools” -> Now on middle part your project listing display then select your project e.g. “MvcApplication1” -> from right side select “set Application Pool Defaults” -> Now change .Net Framework Version from V2.0 to V4.0

This one is work for me but make sure you have already installed .Net Framework 4.0 .

Method 4

Run the following command to fix this problem.

Start –> Run:

%windir%Microsoft.NETFrameworkv4.0.30319aspnet_regiis.exe –i

If you get an error about ADMIN rights you need to do the following.

1. CTRL+SHIFT+ENTER from the RUN menu will run as ADMIN
2. START --> PROGRAMS --> ACCESSORIES --> Right-click on command prompt and "run as administrator"

Method 5

You can also open your projects property pages in VS, and in “Build” section choose as “Target Framework” – .NET Framework 4. It helped me with the same issue.

Method 6

Open your IIS, click on your application pool and change the settings there. Click the defaultAppPool and check the .Net Clear version if version 4.0 is present. you can perhaps change the pipeline mode to integrated.

Method 7

  • Your current .Net Framework version 2.0.
  • .Net Framework Version 4.0(or more than 4.0) is not installed on your server.
  • Update your .Net Framework Version. If not solved yet, you have to change your IIS .Net Framework Version settings and select the .Net Framework Version 4.0.


All methods was sourced from stackoverflow.com or stackexchange.com, is licensed under cc by-sa 2.5, cc by-sa 3.0 and cc by-sa 4.0

0 0 votes
Article Rating
Subscribe
Notify of
guest

0 Comments
Inline Feedbacks
View all comments
0
Would love your thoughts, please comment.x
()
x